• End device tracking

    Hello, Iam using Arduino MKR 1300 WAN as an end device with some sensors. I want to get geoghraphical coordinates with Collos integration on TTN. I programmed the end device with Arduino IDE and I am sending the sensor data to myDevices with a Cayenne LPP-format. Now the question: How do I use the collos integration to get coordinates. I do not have any gateways and currently using the public ones at TTN. I read about sending a http request to obtain coordinates. But from where do I send this http request? Do i send it from my end device? my end device is only coonected to Lora and no WiFi nor internet. Do I write a script in the TTN payload format decoding function, in that case the javascript code example from your website does not work. I am working on a thesis at Malmö University in Sweden and need urgent help, please. Kind Regards Louay

    Status: Proposed | Reported by Hidden Wed, 08 Aug 2018 13:25:02 GMT
  • update gateway with v2 API

    I'm trying to user the update API for the gateway but it doensn't work. Add a gateway into the collos platform POST https://api.preview.collos.org/gateway-management/v2/gateways HTTP/1.1 Host: api.preview.collos.org Content-Type: application/json Ocp-Apim-Subscription-Key: ec94e77f54334cc28464624719b1d85a { "label": "test", "antennas": [ { "id": 0, "position": { "latitude": 0.0, "longitude": 0.0, "altitude": 0.0 } } ], "ownerId": "a2asc", "type": "a2a" } Responce status 200OK { "label": "test", "uniqueId": "e2554620-51d1-486d-ba2e-0c1e47e467ec", "chipId": null, "protocol": "lora", "key": null, "antennas": [{ "id": 0, "position": { "latitude": 0.0, "longitude": 0.0, "altitude": 0.0 } }], "ownerId": "a2asc", "type": "a2a" } Then I tried to update the gateway "e2554620-51d1-486d-ba2e-0c1e47e467ec" just added PUT https://api.preview.collos.org/gateway-management/v2/gateways/e2554620-51d1-486d-ba2e-0c1e47e467ec/owner/a2asc HTTP/1.1 Host: api.preview.collos.org Content-Type: application/json Ocp-Apim-Subscription-Key: ec94e77f54334cc28464624719b1d85a { "label": "test2", "antennas": [ { "id": 0, "position": { "latitude": 1.0, "longitude": 1.0, "altitude": 1.0 } } ], "ownerId": "a2asc", "type": "a2a" } Responce Status 400 bad request Pragma: no-cache Cache-Control: no-cache Date: Wed, 01 Aug 2018 14:10:07 GMT X-Powered-By: ASP.NET Content-Length: 211 Content-Type: application/json; charset=utf-8 Expires: -1 { "error": { "code": "BadArgument", "message": "gatewayId does not match any of label, unqiueId or chipId", "target": "gatewayId", "details": null, "innerError": null }, "correlationId": "787dd166-8bde-4e31-8761-9ebf45b5ce78" } Could you explain me this behavior?

    Status: Proposed | Reported by Hidden Wed, 01 Aug 2018 14:26:25 GMT
  • add gateway with v1 API

    I need to add some gateway into the collos platform and use the V1 APIs the just only available Currently the I can add new gateways on only with the v2 API Is it possible to restore the add function for the gateways until the v2 API will be avaliable? best

    Status: Proposed | Reported by Hidden Thu, 07 Jun 2018 14:26:17 GMT

You're not signed in. Please sign-in to report an issue or post a comment.